[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

To whoever will take over mysql (... and to everybody else thinking about playing games with version numbers)



Please DO NOT DO THIS AGAIN:

+++
$ apt-cache policy mysql-server-4.1
mysql-server-4.1:
  Installed: (none)
  Candidate: 5.0.32-7etch1
  Version table:
     5.0.38-3 0
        600 http://syydelaervli unstable/main Packages
     5.0.38-1 0
        700 http://syydelaervli lenny/main Packages
     5.0.32-7etch1 0
        800 http://syydelaervli etch/main Packages
     4.1.11a-4sarge7 0
        199 http://syydelaervli sarge/updates/main Packages
        199 http://syydelaervli sarge/main Packages
+++

An unfortunate string of events lead me to upgrade a server from sarge to 
etch, using the mysql-server-4.1 package and stupidly assuming that a 
package with the package name "mysql-server-4.1" would contain a MySQL 
server version 4.1.  Cost me quite some time to undo the damage (juggling 
backup tapes, merging database contents etc.) because one application is 
not entirely MySQL 5 compatible and thus partly corrupted the database.

Providing no transition path is better than this.  If aptitude had told me 
that it needs to uninstall mysql-server-4.1, I'd have noticed.

cheers
-- vbi

-- 
We warn the reader in advance that the proof presented here depends on a
clever but highly unmotivated trick.
		-- Howard Anton, "Elementary Linear Algebra"
-- 
If the thunder don't get you, then the lightning will.

Attachment: pgpt3EooQNI9S.pgp
Description: PGP signature


Reply to: