[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PostgreSQL in Lenny, and the libpq transition

Stefano Zacchiroli <zack@debian.org> wrote:
> On Sat, Apr 14, 2007 at 02:48:47PM +0200, Martin Pitt wrote:

> Hi Martin, many thanks for your work!

>>  * Library transition: 8.2 changed a tiny tiny thing in the ABI, so
>>    that a soname bump was necessary. With today's upload, libpq-dev
>>    will cause packages built against libpq5. In order to get rid of
>>    libpq4 and postgresql-8.1, all ~ 100 packages which depend on
>>    libpq4 need to be rebuilt. There should not be any API

> Can you please produce a dd-list of the packages which will need
> rebuilding? Many thanks in advance!

"whodepends libpq4" will output them.
cu and- Imho there is not much point to posting the list, since this
part of the translation can be handled better by binary NMUs. -reas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'

Reply to: