[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

MySql broken on older 486 and other cpuid less CPUs. Does this qualify as RC?

Bug 410474 involves mysql not working on older 486s and some cyrix cpus
which do not have the cpuid instruction.  Any program that tries to use
libmysql (proftpd, php, etc) terminates with illegal instruction.

Upstream tried to fix it, but apparently failed to do so correctly,
although I suspect it does work on BSD if nothing else.

Since I run a 486, and deviced it was time to upgrade to Etch, to see if
there were any issues to report about it before the release happens, I
was rather surprised when proftpd suddenly didn't work.  Commenting out
the mysql module in proftpd's config made it work.  Then I noticed php
didn't work either, if it had mysql enabled, and I tracked down this bug

I have now found a solution to the problem (which makes it solved not
just on BSD where setjmp saves signal context by default, which linux
does not), and added it to the bug.  Of course I don't know if the mysql
maintainer is actually around at the moment to notice and do something
with it.

So does it seem fair to raise the severity to flag mysql as release
critical for etch since it does affect any program that links in
libmysql running on any x86 without cpuid support?  I would hate to see
other people upgrade to Etch on older systems that were working find
just to end up with a bunch of programs no longer working.

Len Sorensen

Reply to: