[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What is the reason glibc is at version 2.3 for etch?



On Thu, Mar 22, 2007 at 09:23:21PM +1100, Lex Hider wrote:
> Hi,
> I've been discussing with some #fluendo people about their codecs not being 
> compatible with etch (requires glibc 2.4+).

  too bad for them.

> Can anyone give a brief answer to why etch will be shipping the glibc at 2.3.
> I couldn't provide an explanation as to why it is only 2.3 being shipped.

  Especially because 2.4 would have meant dropping many archs support. I
think 2.5 will deal with that better, but that would have been obviously
wrong to aime 2.5 at etch.

  AFAICT hppa and m68k are currently in a hiatus, even with libc2.5, as
we will probably drop linuxthreads support, and that no viable NPTL port
exists yet.

Cheers,
-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpP91CE2Clz3.pgp
Description: PGP signature


Reply to: