[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405961: ITP: emdebian-tools -- emdebian crossbuilding tool set

Package: wnpp
Severity: wishlist
Owner: Neil Williams <codehelp@debian.org>

* Package name    : emdebian-tools
  Version         : 0.0.2
  Upstream Author : Neil Williams <codehelp@debian.org>
* URL             : http://buildd.emdebian.org/repos/tools/em_make/
* License         : GPL
  Programming Lang: Perl
  Description     : emdebian crossbuilding tool set

 A collection of scripts to ease cross-building Debian packages for
 Emdebian, reducing package size, separating translations into
 individual files and handling dependencies.
 emsetup : Check your system for cross-build support and determine some
 defaults for other emdebian-tools scripts. Run this first, using the 
 simulate option to see what changes may be needed.
 emchain : Toolchain builder for cross compiling. If a pre-built
 toolchain is not found or not available, emchain can build a custom 
 toolchain for your needs using the current Debian version of gcc.
 em_make : Emdebianise a Debian package. Creates suitable changelog
 entries, omits certain debhelper scripts from debian/rules and 
 maintains a patchset for emdebian. Removes all documentation and 
 udeb packages from debian/control.
 emlocale : Moves all translations out of the Debian package(s) and into
 individual locale packages, allowing the embedded user to only install
 the translations that are relevant to that system. First run is via
 em_make, subsequent runs update the list of available translation 
 emdebuild : Emdebian version of debuild that handles cross-building the
 emdebianised tree. Requires a suitable cross-building toolchain to be
 installed for the requested architecture, e.g. gcc-4.1-arm-linux-gnu,
 available from the emdebian tools repository via emsetup or built for
 your particular configuration using emchain.
 Homepage: http://www.emdebian.org/

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-amd64-k8
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)

Reply to: