[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405230: ITP: python-coverage -- coverage testing tool for Python

Package: wnpp
Severity: wishlist
Owner: Lars Wirzenius <liw@iki.fi>

* Package name    : python-coverage
  Version         : 2.6
  Upstream Author : Ned Batchelder, Gareth Rees
* URL             : http://www.nedbatchelder.com/code/modules/coverage.html
* License         : BSD-like
  Programming Lang: Python
  Description     : coverage testing tool for Python

>From the upstream web site: Coverage.py is a Python module that measures
code coverage during Python execution. It uses the code analysis tools
and tracing hooks provided in the Python standard library to determine
which lines are executable, and which have been executed.

This is useful for developing test suites for Python software.

(This is not really the long description, I'm not far enough yet to 
formulate one.)

I'll co-maintain the package with Wouter van Heyst.

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=fi_FI.UTF-8, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)

Reply to: