[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Fwd: Bug#387557: pcre3: Please ship pcre_internal.h]

What do people think about this?

Personally I feel that the "internal" in the name really should have been a big enough clue, and I don't want to include a file that's not meant to be used just because some idiots have written software that needs it.

I'm not even sure it will work; what is it that emboss wants it for?

--- Begin Message ---
Package: pcre3
Severity: wishlist

Dear Mark,

I am building packages for EMBOSS, the European Molecular Biology
Software Suite (www.emboss.org). They ship an old version of pcre, and
build against it. As a result, the package contains files wich conflict
with Debian's pcre3.

I am trying to solve this by building EMBOSS against Debian's pcre
packages, but EMBOSS uses pcre_internal.h, which is not shipped. Do you
think that you could add them to your packages?

Ahemm... and as I am trying to finish the packaging before the freeze,
do you think that you could add the pcre_internal.h to pcre3 before the
freeze too? Do you need me to submit a patch?

Thanks a lot, and have a nice day,

Charles Plessy
Debian-Med packaging team

--- End Message ---

Reply to: