[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Correct dependencies on libgnutls-dev? (#370387)


On Sun, 18 Jun 2006 20:10:15 +0200
Loïc Minier <lool+debian@via.ecp.fr> wrote:

>  If we were to force all binaries to link to one and only one gnutls,
>  then we wouldn't allow two or three gnutls versions in the archive at
>  the same time.

It's not about forcing one gnutls version for all binaries but forcing
one gnutls version for one binary. This is IMHO reasonable.

I just reported this problem as my sponsor refused to upload resulting
package and I was not aware of anything wrong in it. Anyway moving
libraries needed for static linkage to Libs.private would resolve
shared libraries case as you most likely don't need direct linkage to
gnutls while using libsoup.

	Michal Čihař | http://cihar.com | http://blog.cihar.com

Attachment: signature.asc
Description: PGP signature

Reply to: