[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#374132: ITP: tntdb -- C++ class library for easy database access

This one time, at band camp, Kari Pahula said:
> On Sat, Jun 17, 2006 at 03:46:11PM +0300, Kari Pahula wrote:
> > * License         : GPLv2 or later
> >  Currently has support for MySQL, PostgreSQL and SQLite.
> And PostgreSQL links to openssl, which is GPL incompatible.  Sigh...
> I'll investigate what could be done about this.

If it's a transitive link, is that really an issue?  With newish linker
features, you don't get a NEEDED line for libssl unless you actually
use it's symbols in your app.  I'm not sure, but how far down the tree
of recursive linking is this an issue for?
|   ,''`.                                            Stephen Gran |
|  : :' :                                        sgran@debian.org |
|  `. `'                        Debian user, admin, and developer |
|    `-                                     http://www.debian.org |

Attachment: signature.asc
Description: Digital signature

Reply to: