[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing a package from "Config-files" state earlier than the most recent stable release

Justin Pryzby <justinpryzby@users.sourceforge.net> wrote:

> Does this mean that maintainers should be expected to support the
> maintscript "install" "$2" cases for ancient versions, or is there
> some other convention of which I remain unaware?

I can't speak for any general conventions.  But we had quite a lot of
bug reports against tetex-base because of this: #344212 #351649 #352486
#354444.  Unfortunately, the main discussions were not in the bug
reports, but in private mail with Andreas Tille.  Therefore I can't
check, and some of them might actually be "real" bugs; but most of them
were after I extensively tested upgrading from sarge, and happened for
people who had tetex-extra (or even -base) in purged state since woody.

I ended up catering for all of these; but it wasn't hard in this case
(just add a couple of "filename md5sum" pairs to a list, the former
conffiles are removed when unchanged and moved to a new place when

Regards, Frank
Frank Küster
Single Molecule Spectroscopy, Protein Folding @ Inst. f. Biochemie, Univ. Zürich
Debian Developer (teTeX)

Reply to: