[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Conflict field for logical conflicts?

On Sun, Jun 11, 2006 at 07:39:55PM +0200, Goswin von Brederlow wrote:
> What you want is:
> jed: Provides: jed-abi-23
> jed-extra: Depends: jed-abi-23
> You should add such a provides in jed now and update the jed-extra
> package asap. The next time the ABI changes you bump the provides. If
> the ABI only extends the old one then "Provide: jed-abi-23,
> jed-abi-24".

Great idea, but it doesn't work due to #170825. dpkg allows jed to be
upgraded even though it breaks jed-extra.

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: