Re: Getting rid of circular dependencies, stage 4
On Wed, May 10, 2006 at 07:31:58PM +0200, Dagfinn Ilmari Mannsåker wrote:
>Brendan O'Dea <email@example.com> writes:
>> On Wed, May 10, 2006 at 04:20:19PM +0200, Pierre Habouzit wrote:
>>> (In fact, IMHO nothing should depends from perl-modules at all).
>> Correct. I'd prefer that nothing did.
>Is this documented anywhere? If is really is the case that nothing
>should depend on perl-modules (but rather on perl itself), the Perl
>Policy should mention it in the dependencies section.
Perl Policy is intentionally vague about the way that the package is
split up (into perl, perl-modules or whatever).
The intent was to allow the maintainer to choose the most appropriate
split (if any) and to mandate only the existence of `perl-base', and
ensure that installing the package `perl' would provide a working Perl
Section 5.2 describes program dependencies, and refers only to `perl' or
`perl-base'. The first paragraph could perhaps be re-worded as:
Programs which require <core> Perl modules must specify a
dependency on the `perl' package.
Note that it doesn't say that you shouldn't depend on perl-modules,
merely that you must depend on perl.
>> Selecting a random entry from that list with a versioned dependency,
>> Depends: perl (>= 5.6.0-16), perl-modules (>= 5.8.0) | libparse-recdescent-perl, [...]
>Speaking as co-maintainer of munin, should we just change that to "perl
>(>= 5.8.0) | libparse-recdescent-perl" instead? Won't lintian complain
>about a duplicate relation on perl in that case, or has that been fixed?
>(We want the packages to be installabe on woody with the minimum amount
>of fuss, so we don't want to just depend on perl (>= 5.8.0)).
That dependency is fine. I chose it as an example of where not having
the reverse dependency could cause problems.
This is the sort of thing which I'd prefer not to see:
perl would be correct.
Depends: perl (>= 5.8.4-5) | perl-modules, perlapi-5.8.4, libc6 (>= 2.3.5-1), libplrpc-perl
A specific version of perl or *any* version of perl-modules?
Depends: perl, perl-modules, perl-tk
Depends: perl-base (>= 5.6.0), perl-modules, liblocale-gettext-perl, libtie-ixhash-perl, coreutils (>= 4.5.0) | fileutils (>= 4.1), debconf (>= 1.0.32)
The first two should be replaced by "perl (>= 5.6.0)".