[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting rid of circular dependencies, stage 4

On Thursday 11 May 2006 01:25, Frank Küster wrote:

> The only things that should be installed separately are

> probably aptitude, apt and dpkg, then just dist-upgrade.


From memory, upgrading apt + friends seperately isn't possible whilst synaptic is installed. In sarge, the gnome meta package depends on synaptic, so this probably applies to a lot of desktop systems.

In sarge, synaptic depends on libapt-pkg-libc6.3-5-3.3, which is provided by apt.

In etch, apt provides libapt-pkg-libc6.3-6-3.11, which matches the depends of synaptic in etch.

Adding CC to APT Development Team <deity@lists.debian.org> since I'm wondering whether the changes to apt really required dropping the provides of libapt-pkg-libc6.3-5-3.3?

For the future, could apt provide a real library, hence solving this problem for etch+1?

Andrew V.

Reply to: