[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Adding dependencies to e2fsprogs: libdevmapperr, libselinux and libsepoll

Theodore Ts'o <tytso@mit.edu> writes:

> Actually, because of the e2fsck-static package, e2fsprogs has to have
> a build-depends on libselinux.  There doesn't seem to be a way to say,
> "except on non-Linux platforms" for a build-depends as far as I know,
> unfortunately.  Any suggested solutions?

I believe

Build-Depends: dpkg-dev (>= 1.13.12), libselinux-dev [linux-any], ...

is supposed to work nowadays.

Aaron M. Ucko, KB1CJC (amu at alum.mit.edu, ucko at debian.org)
Finger amu@monk.mit.edu (NOT a valid e-mail address) for more info.

Reply to: