[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages that need to be rebuilt agaisnt libssl0.9.8

martin@uni-mainz.de wrote:
> But I don't think that versioning the
>symbols in Debian alone would be such a good idea. Than we would be
>incompatible with other distributions.
Well, only in one direction if I remember my versioning rules correctly.
Consider the following cases:
* binary built against unversioned libssl from other distro, running with 
versioned libssl on Debian
Breaks because it can't find the symbols.
* binary built against versioned libssl on Debian, running with unversioned 
libssl on other distro
Works, because if it can't find a versioned symbol, it tries the unversioned 

This can be fixed even more by keeping available one version of libssl with 
unversioned symbols, and versioning the symbols on all other versions.  Then 
binaries from other distros will work as long as the unversioned-symbol 
version is available (and compatible, of course).

Nathanael Nerode  <neroden@twcny.rr.com>

Make sure your vote will count.

Reply to: