[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#334530: ITP: libcatalyst-engine-apache-perl -- Base class for Apache 1.99x and 2.x Catalyst engines

Package: wnpp
Severity: wishlist
Owner: "Krzysztof Krzyzaniak (eloy)" <eloy@debian.org>

* Package name     : libcatalyst-engine-apache-perl
  Version          : 0.99
  Upstream Authors : Sebastian Riedel, <sri@cpan.org>, 
  	   	     Christian Hansen, <ch@ngmedia.com>, 
		     Andy Grundman, <andy@hybridized.org>
* URL              : http://www.example.org/
* License          : (perl: Artistic/GPL)
  Description      : Base class for Apache 1.99x and 2.x Catalyst engines

 Catalyst is an elegant web application framework, extremely flexible yet
 extremely simple. It's similar to Ruby on Rails, Spring (Java) and Maypole,
 upon which it was originally based.
 Catalyst follows the Model-View-Controller (MVC) design pattern, allowing you
 to easily separate concerns, like content, presentation, and flow control,
 into separate modules. This separation allows you to modify code that handles
 one concern without affecting code that handles the others. Catalyst promotes
 the re-use of existing Perl modules that already handle common web application
 concerns well.
 This is a base class for Apache 1.99x and 2.x Engines.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-686
Locale: LANG=pl_PL, LC_CTYPE=pl_PL (charmap=ISO-8859-2)

Reply to: