[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-Depend'ing on libasound2-dev just for Linux

* Lawrence Williams [Thu, 15 Sep 2005 13:13:14 -0230]:

> I seen an example of a possible choice in xorg-x11 packages that Build-Dep on 
> linux-kernel-headers, but I wasn't sure if I should follow their example:

> linux-kernel-headers (>= 2.6.13+0rc3-1.1) 
> [!hurd-i386 !netbsd-i386 !kfreebsd-i386]

> In Debian, does this prevent it from building on anything other than Linux??

  Of course not, read Policy. What is saying is, "this package needs
  l-k-h to build, _unless_ we're on hurd-i386, netbsd-i386, or
  kfreebsd-i386; in that case, it's ok that l-k-h is not present".

* David Moreno Garza [Thu, 15 Sep 2005 12:10:38 -0500]:

> On Thu, 2005-09-15 at 13:05 -0400, Kevin B. McCarty wrote:
> > Doesn't the type-handling package do what you guys are looking for?

> Yes, it does. And it rocks.

  No, it does not (rock). And, fortunately, it's going to die. If you're
  curious what's going to replace it, check Guillem Jover's patch in
  #291939 (last message in the bug).

  When/if it gets implemented, you'll be able to:

    Build-Depends: libasound2-dev [linux-any]
    Build-Depends: firebird2-dev  [any-i386]


Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
I went to the race track once and bet on a horse that was so good that
it took seven others to beat him!

Reply to: