[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Qt, aRts and KDE C++ ABI transitions: time to upload your packages


 I'm in the following case:

On Thu, Sep 01, 2005, Adeodato Simó wrote:
>       2. Your package already depends on the transitioned libraries because you
>          re-uploaded right after they became available with the necessary
>          version constraint in your Build-Depends line.
>          This was your choice to make, and fortunately it ensures that all
>          buildds will have built your package against the transitioned packages.
>          Still, you may want to consider reverting, in your next upload, the
>          Build-Depends version constraint to what you previously had (unless
>          such bumping was unrelated to the C++ ABI transition, like is the case
>          with the official KDE modules maintained by the Debian Qt/KDE
>          Maintainers, or your package is a library, like dbus).

 But I'm not sure of why I should do this.  Is it to relax build-deps
 constraints for eg. backports?


Loïc Minier <lool@dooz.org>

Reply to: