[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: invalid-arch-string-in-source-relation amd64

2005/8/24, Tollef Fog Heen <tfheen@err.no>:
> * Shaun Jackman
> | What's wrong with this Build-Depends line?
> |
> | Build-Depends: ia32-libs-dev [amd64], debhelper (>= 4.1.16)
> Unless eagle is a toolchain package, you shouldn't build-dep on
> ia32-libs-dev.  ia32-libs-dev is a helper package to bootstrap biarch
> compilers, and not suitable for general development.

eagle (the package on topic) is a binary non-free i386 package. I was
told that it needs a build dependency on ia32-libs-dev for
dh_shlibdeps. The relevant bug is #306312.


Bug #306312: eagle: FTBFS (amd64): Please add amd64 support
Package: eagle
Version: 4.11-8
Severity: wishlist
Tags: patch

When building 'eagle' on amd64/unstable,
I get the following error:

/usr/bin/ldd: line 171: /lib/ld-linux.so.2: No such file or directory
ldd: /lib/ld-linux.so.2 exited with unknown exit code (127)
dpkg-shlibdeps: failure: ldd on `debian/tmp/usr/share/eagle/bin/eagle'
gave error exit status 1
dh_shlibdeps: command returned error code 256
make: *** [binary-arch] Error 1

With the attached patch 'eagle' can be compiled on amd64.

Andreas Jochens

Reply to: