[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How coldplug works



Hi Marco!

On Tue 23 Aug 2005 09:57 +0200, Marco d'Itri wrote:
> On Aug 23, Isaac Clerencia <isaac@debian.org> wrote:
>
>> I've just tried it and it has worked really great, except it has not loaded 
>> mousedev module. Everything else has worked, and it's incredible fast (at 
> It's supposed to, do you mind investigating? Do not delete the
> generated events, etc. Try manually running the init script a second
> time too.
> I noticed that on my system the first time it's run the ehci_hcd is not
> loaded, but I have not yet found why.

I just gave coldplug a try.

First of all, my Debian:

- unstable, just upgraded (not dist-upgrade, but a simple upgrade)

- vanilla 2.6.13-rc6 + ACPI patch dated 20050729 (compiled with
  make-kpkg), external modules are ALSA, cdfs, ieee80211, ipw2100,
  pwc, qc-usb and thinkpad

- udev 0.068-1 (and `dpkg --purge --force-all hotplug` ;-) )

- IBM ThinkPad T42p + docking station


And here the results (differences versus hotplug):

- mousedev is correctly loaded, but this is not the case for psmouse
  (so, it automatically starts xdm, but I need to manually load
  psmouse)

- no sound at all (the ALSA modules are not loaded)

- no wired network (I use the e1000 driver), while the ipw2100 module
  is automatically loaded

- otherwise, it seems to work correctly (I tried plugging in an
  external USB drive and scsi_mod, usb_storage and sd_mod are
  correctly and automatically loaded, but not uloaded)


BTW, as you suggested, I tried to manully run the init script
two/three times, but nothing changed.

I'm available for others test if you need (and I'm on Freenode as
gismo).

Thx, bye,
Gismo / Luca

Attachment: pgpKRCYu3dsG0.pgp
Description: PGP signature


Reply to: