[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Yet another g++ transition page



On Monday 18 July 2005 11:23 am, Mike Furr wrote:
> Daniel Burrows wrote:
> >   I think you need to take virtual packages into account; apt-based stuff
> > is showing up in Level 1, which AIUI is wrong.
>
> Well, it does the best it can.  It resolves all of the information it
> has available.  However, for example, apt-move has a dependency on
> libapt-pkg-libc6.3-5-3.3 which is not provided by any package currently
> in unstable so my tool has no possible way of resolving this.  If it
> depended on libapt...-3.9, then it would correctly correlate this with
> the "apt" package.

  Whoops, I see.  So, just to further my comprehension here, why doesn't apt 
show up in the dependency tree of aptitude?  Obviously libsigc has gone 
through the transition already, so it's not listed, but I'm quite certain 
that apt hasn't.

  Daniel

-- 
/------------------- Daniel Burrows <dburrows@debian.org> ------------------\
|                      Gil-Galad was an Elven king;                         |
|                      of him the harpers sadly sing.                       |
\--------------------- A duck! -- http://www.python.org --------------------/

Attachment: pgpyz1DYFxHLa.pgp
Description: PGP signature


Reply to: