[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#295131: JFTR: sdl(glib2.0) vs. wx2.4(glib1.2) only affects scorched3d

On Thursday 24 March 2005 14:37, Bartosz Fenski aka fEnIo wrote:
[analysis skipped]
> I'm not sure what to do now. Is it possible to link our wxgtk2.4 against
> glib2.0? Or unlink libsdl from using libglib?

I found the cause:

libSDL.so from libsdl1.2debian-all links against glib2.0 (and much other 

libSDL.so from libsdl1.2debian-alsa:

zion:~# ldd /usr/lib/libSDL.so  | sort
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xb7e7c000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xb7e6e000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb7dba000)
        libc.so.6 => /lib/tls/libc.so.6 (0xb7c52000)
        libdl.so.2 => /lib/tls/libdl.so.2 (0xb7d95000)
        libm.so.6 => /lib/tls/libm.so.6 (0xb7d98000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7d86000)

scorched3d loads fine for me now, I could start a game (though textures were 
messed up).

Looking at Depends of libsdl1.2debian-*, a Conflicts: libsdl1.2debian-all, 
libsdl1.2debian-arts would probably help.

Regards, David

- hallo... wie gehts heute?
- *hust* gut *rotz* *keuch*
- gott sei dank kommunizieren wir über ein septisches medium ;)
 -- Matthias Leeb, Uni f. angewandte Kunst, 2005-02-15

Reply to: