[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#291945: eleventh-hour transition for mysql-using packages related to apache

On Fri, Feb 11, 2005 at 03:30:59PM -0800, Steve Langasek wrote:
> On Fri, Feb 11, 2005 at 03:31:44PM +0100, Christian Hammers wrote:
> > On 2005-02-11 sean finney wrote:
> > > On Fri, Feb 11, 2005 at 10:15:55AM +0100, Francesco P. Lovergine wrote:
> > > > FYI: new mysql FLOSS includes OpenSSL license, so many packages could
> > > > migrate to current libmysqlclient starting from no starting from now..
> > > that's great to hear!  i'm cc'ing the relevant wishlist bug i have open
> > > against mysql-server.  christian: any chance of getting an openssl enabled
> > > version of the mysql-client and mysql-server packages?
> > Yes, I will re-enable openssl in the next upload.
> Please make sure this does not introduce an openssl dependency to
> libmysqlclient itself; just because MySQL AB have granted a license
> exception for OpenSSL does not mean everyone who links to libmysqlclient
> has done so.
> I know of at least one GPL-without-exception package that is now using
> libmysqlclient12 in Debian.

Nice, so we should check that any linked GPL library directly (obviuolsy) or
indirectly (with N=1,2,3... levels of indirection) linked against
openssl adds the exception. This is a great reason to move asap all
possible programs to gnutls, indeed.

Francesco P. Lovergine

Reply to: