[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#276606: ITP: libsub-override-perl -- Perl module used to temporarily override subroutines

Package: wnpp
Severity: wishlist

  Package name    : libsub-override-perl
  Version         : 0.05
  Upstream Author : Curtis "Ovid" Poe
  URL             : http://cpan.org/modules/by-module/Sub/Sub-Override-0.05.tar.gz
  License         : Perl
  Description     : Perl module used to temporarily override subroutines
   This is the CPAN module Sub::Override.
   Perl programmers sometimes have a need to override subroutines,
   particularly for testing purposes.  Sub::Override provides a simple
   way to override subroutines instead of using heavier-weight methods
   such as Mock Objects.

I'm packaging this because the latest libhtml-tokeparser-simple-perl
requires it.


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.25-1-386
Locale: LANG=en, LC_CTYPE=en_US (ignored: LC_ALL set to en_US)

Kenneth J. Pronovici <pronovic@debian.org>

Attachment: pgpAHreij68CM.pgp
Description: PGP signature

Reply to: