[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274550: ITP: xerces26 -- Validating XML parser library for C++

Package: wnpp
Severity: wishlist

* Package name    : xerces26
  Version         : 2.6.0
  Upstream Author : xerces-c-dev@xml.apache.org
* URL             : http://xml.apache.org/xerces-c/
* License         : Apache Software License
  Description     : Validating XML parser library for C++

 Xerces-C++ is a validating XML parser written in a portable subset of
 C++.  Xerces-C++ makes it easy to give your application the ability
 to read and write XML data. A shared library is provided for parsing,
 generating, manipulating, and validating XML documents. Xerces-C++ is
 faithful to the XML 1.0 recommendation and associated standards (DOM
 1.0, DOM 2.0, SAX 1.0, SAX 2.0, Namespaces, XML Schema Part 1 and
 Part 2).  It also provides experimental implementations of XML 1.1
 and DOM Level 3.0.  The parser provides high performance, modularity,
 and scalability.

xerces23, xerces24, and xerces25 are all also in Debian.  For reasons
previously discussed on debian-devel, multiple versions of the xerces
packages have to be there at the same time.  Executive summary: a
non-trivial amount of external software depends upon specific versions
of xerces, and external packages often lag behind in updating their
software to work with new versions.  There are specific known
dependencies on all the above-mentioned versions.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-1-k7
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8

Reply to: