[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#257274: ITP: clanlib0.7 -- multi-platform game SDK (development version)

On Wed, Jul 14, 2004 at 10:46:13PM +0200, Bartosz Fenski aka fEnIo wrote:
> > Which brings up the obvious question, why do they still classify it as
> > development/unstable? Why don't they release it?
> Well they're releasing it all the time, but as a development branch.
> Maybe because of that many programs still using stable branch?
> I don't know, but I'll try to get info from upstream about that.

Here goes answers from clanlib-devel mailing list:

[Kelly Kevin - don't know who is he]
0.7.x is 1000% better than 0.6.x, and probably *more* stable -- at least
from my experience.

[Kenneth Gangstoe - one of the upstream author]
Yes, we recommend users to use 0.7.x.

No, we don't call it stable, because we have some outstanding API issues we
want to sort out before 0.8. Now, this process is dragging out, so the
users are kind of stuck with an "unstable" version that is pretty stable.

Sorry, I can't give any time estimates on when 0.8 is out. My suggestion
would be to package it as it is.

What about packaging Clanlib0.7 now?

I intend to adopt package race, and it is outdated in our archives.
I can't update it without new clanlib. I can't package flexlay without new
clanlib too.

Also some other developers expressed their interest in this branch.


      _      Bartosz Fenski | mailto:fenio@o2.pl | pgp:0x13fefc40 | IRC:fEnIo
    _|_|_     32-050 Skawina - Glowackiego 3/15 - w. malopolskie - Polska
    (0 0)          phone:+48602383548 | Slackware - the weakest link
ooO--(_)--Ooo  http://skawina.eu.org | JID:fenio@jabber.org | RLU:172001

Attachment: signature.asc
Description: Digital signature

Reply to: