[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Package build failure on powerpc

On Mon, Apr 05, 2004 at 08:50:24PM -0400, Sam Hartman wrote:
> >>>>> "Andrew" == Andrew Pollock <apollock@debian.org> writes:
>     Andrew> Hi, I've had a package build fail[0] for the last upload I
>     Andrew> made of a package I maintain (just on powerpc).
>     Andrew> From my interpretation of the build log, it looks like
>     Andrew> something went awry in the build environment, and it isn't
>     Andrew> necessarily a problem with my package.
> I di a quick
> apt-get build-dep argus
> apt-get source argus
> cd directory
> dpkg-buildpackage -us -uc -rfakeroot -B
> and it failed trying to install files that did not exist.

Yeah? I just did the above in a sid chroot on i386, and it worked fine, so
it's not a problem across the board.
> If after looking at the build log more closely you can still not
> determine the problem let me know and I'll actually look closely at
> what is going on.

Well, it's this sort of stuff:

make[1]: Entering directory `/build/buildd/argus-2.0.6.rc2'
### Making in /build/buildd/argus-2.0.6.rc2/common
make[2]: Entering directory `/build/buildd/argus-2.0.6.rc2/common'
gcc -mpowerpc64 -O2 -I. -I../include -I/usr/include  -DPACKAGE_NAME=\"\"
-DARGUS_SYSLOG=1 -c ./argus_parse.c
argus_parse.c: In function `argus_parse_init':
argus_parse.c:155: internal compiler error: in expand_call, at calls.c:3312
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[2]: *** [argus_parse.o] Error 1
make[2]: Leaving directory `/build/buildd/argus-2.0.6.rc2/common'

that makes me suspect something is afoot in the buildd environment itself.
> (This test performed on a sarge powerpc system)

Methinks I will have to play on a powerpc machine...


Reply to: