[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Library packages depending on data files

On Wed, Feb 04, 2004 at 01:07:33PM +0000, Colin Watson wrote:
> On Wed, Feb 04, 2004 at 02:02:05PM +0100, Adrian Bunk wrote:
> > On Tue, Feb 03, 2004 at 01:10:51AM +0000, Andrew Suffield wrote:
> > > This is not an option. If you do this, you will be crucified.
> > > 
> > > It is necessary to support having multiple ABI versions of a library
> > > installed at once.
> > 
> > Why?
> Two words: upgrade hell.

For whom?

The most important thing is whether there are problems for the users,
and situations like being able to install libssl0.9.6 and libssl0.9.7 at
the same time are problems waiting to occur when people will do e.g.
partial upgrades from Debian 3.0 to Debian 3.1, since it might happen 
that one application links (via a different lib) with two so-versions 
of libssl at the same time.

Compared to these user visible problems, I'd consider the issues like 
having to recompile all packages in unstable and the babysitting testing 
requires less important.

> Colin Watson                                  [cjwatson@flatline.org.uk]



       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Reply to: