[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Autobuilders messed up dependencies of stable libpgperl

Hello everybody,

We just received #229151 against libpgperl (perl frontend for
postgresql), which says:

	libpgperl (version 7.2.1-2woody4) in stable/binary-sparc
	depends on wrong version of perl for this stable:

	perl (>= 5.6.1-8.6), libperl5.6 (>= 5.6.1-8.6)

According to the package page [1], its perl dependencies are
completely messed up. The PTS [2] says that there is no such thing
like perl 5.6.1-8 or -8.3, although -8.3 exists in the pool.

But neither in the pool nor in the PTS exists -8.6, so how can it be
that the respective autobuilders inserted wrong perl versions on all
arches but s390? (we built it correctly on i386, so no autobuilder here).

In the source package the dependency is generated with dh_perl (it
says ${perl:Depends}), so the only possibility I can think of is that
there are unofficial perl packages on the autobuilders.

What can we do about it? May we upload a new libpgperl package into

Thanks and have a nice day!

Martin Pitt (postgresql comaintainer)

[1] http://packages.debian.org/stable/libs/libpgperl
[2] http://packages.qa.debian.org/p/perl.html

Martin Pitt                 Debian GNU/Linux Developer
martin@piware.de                      mpitt@debian.org
http://www.piware.de             http://www.debian.org

Attachment: signature.asc
Description: Digital signature

Reply to: