[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Removal of libtool1.4

Scott James Remnant <scott@netsplit.com> writes:

> Don't panic just yet, this is only a proposal and I've not yet decided
> whether this is going to happen; and if so, when it will happen.  If you
> require this package, now is the time to speak up and let your voice be
> heard (on the mailing list is preferred).

With my Gimp-Print upstream hat on: our current stable release
(4.2.x), of which 4.2.6 (released today) is the latest use autoconf
2.13, automake 1.4 and libtool 1.4 for building (and upgrading the
autotools is not an option--extensive portability testing has been
done with the existing setup, and I also wrote a lot of custom m4).  I
do use Debian for development (including bootstrapping from CVS), and
so I do need the tools.

(Our current development release, 5.0.0-alpha1 uses all the latest
autotools, and has done so for well over a year.)

This requirement should not be needed for long: 4.2.6 is expected to
be the last 4.2 release, but this is not set in stone.  I also use a
woody chroot for development, but this is a pain and not really ideal.

Others may also be in the same situation.  It would be nice if libtool
1.4 was part of Sarge, but I don't have strong feelings this way--I
can always use the woody chroot (other factors, such as flex, prevent
development on a current testing/unstable).


Roger Leigh

                Printing on GNU/Linux?  http://gimp-print.sourceforge.net/
                GPG Public Key: 0x25BFB848.  Please sign and encrypt your mail.

Reply to: