[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Linux header breakage in non-i386 builds

On Tue, Dec 30, 2003 at 11:53:24AM -0400, Ben Armstrong wrote:
> My 'came' package is broken on several non-i386 arches due to errors in
> included linux kernel headers.  See the 1.7.cvs.20031217-1 builds here:
> http://buildd.debian.org/build.php?pkg=came
> I have been told I can simply include the headers in my own package.  Is 
> this the correct solution, and if so, why?

There's plenty of documents on `why'. Boils down to "kernel headers are
not meant for userspace programs". If you use them, you will break.

Debian     - http://www.debian.org/
Linux 1394 - http://www.linux1394.org/
Subversion - http://subversion.tigris.org/
WatchGuard - http://www.watchguard.com/

Reply to: