[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

chown 0:0 testfile hangs

I have two systems confirmed that show the following behaviour:


Debian version:  testing
Kernel:  2.4.21-powerpc (from standard debian package)
Glibc:  2.3.2-7

Intel Box

Debian version:  testing
Kernel 2.4.22-1-686
Glibc: 2.3.2-7

On both machines I have one group with a large membership (The powerpc
machine has a group with 1281 characters on the line, the intel box has a
group with 4056 characters on that group's line in /etc/group.

With these large groups when I run:

chown 0:0 testfile

The command appears to hang.  When I run:

strace chown 0:0 testfile

The following calls repeat in a loop:

open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0_\1\000"...,
		512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1230864, ...}) = 0
old_mmap(NULL, 1236292, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) =
old_mmap(0x40142000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
		3, 0x127000) = 0x40142000
old_mmap(0x40147000, 7492, PROT_READ|PROT_WRITE,
close(3)                                = 0

The calls are the same on both boxes.  If I remove the one large group
from /etc/group, then the chown command completes immediately as I'd
expect.  Is this a bug in glibc?  Is there some limit on the length of
lines in /etc/group?


Reply to: