[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libpng3 upgrade will remove kde development packages

The new libpng3 ( renames libpng12-0-dev to libpng12-dev, which 
seems to be intentional on the part of the new maintainer.  I have a number 
of kde development packages which depend on libpng12-0-dev, though, and so 
will be removed if I upgrade libpng3.


Shuttle:/home/josh# apt-get -s install libpng3
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
The following packages will be REMOVED:
  kdelibs4-dev kdesdk kspy libarts1-dev libartsc0-dev libpng12-0-dev
The following held packages will be changed:
  libpng12-0 libpng3
2 packages upgraded, 0 newly installed, 7 to remove and 7  not upgraded.
Remv kdesdk (4:3.1.1-1 Debian:unstable)
Remv kspy (4:3.1.1-1 Debian:unstable)
Remv kdelibs4-dev (4:3.1.1-1 Debian:unstable)
Remv libartsc0-dev (1.1.1-2 Debian:unstable)
Remv libarts1-dev (1.1.1-2 Debian:unstable)
Remv libqt3-mt-dev (3:3.1.1-7 Debian:unstable)
Remv libpng12-0-dev (1.2.5-11 )
Inst libpng3 ( Debian:unstable) []
Inst libpng12-0 ( Debian:unstable)
Conf libpng12-0 ( Debian:unstable)
Conf libpng3 ( Debian:unstable)

Should I file any bugs? If so, against libpng3, or against the other packages?

Thank you,

Reply to: