[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libpng problems still?



Hi,

Sorry to trouble people, but I can't seem to work out why the libpng-dev package for debian testing is uninstallable for me. when I go `apt-get install libpng-dev` I get

Sorry, but the following packages have unmet dependencies:
  libpng-dev: Depends: libpng3 (= 1.2.1-1.1) but 1.2.1-1.1.woody.1 is to be installed
E: Sorry, broken packages

However, `apt-cache showpkg libpng3` gives

Package: libpng3
Versions: 
1.2.1-1.1.woody.1(/var/lib/dpkg/status)
1.2.1-1.1(/var/lib/apt/lists/nevermind:9999_debian_dists_testing_main_binary-i386_Packages)
..blah blah...
Dependencies: 
1.2.1-1.1.woody.1 - libc6 (2 2.2.4-4) zlib1g (2 1:1.1.4) 
1.2.1-1.1 - libc6 (2 2.2.4-4) zlib1g (2 1:1.1.3) 
Provides: 
1.2.1-1.1.woody.1 - 
1.2.1-1.1 - 
Reverse Provides: 

So it seems that the dependency should be met :/ Is there something obvious that I'm not seeing? Also, what's the news on the whole libpng mess that people were discussing a few months ago?

Much appreciated,

Nick



Reply to: