[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

binutils-dev dependency problem...

Nobody replied on debian-mentors, so I'm posting here...

----- Forwarded message from Adam Byrtek <alpha@student.uci.agh.edu.pl> -----

Date: Tue, 10 Sep 2002 16:43:02 +0200
From: Adam Byrtek <alpha@student.uci.agh.edu.pl>
Reply-To: Adam Byrtek <alpha@irc.pl>
To: debian-mentors@lists.debian.org
Subject: binutils-dev dependency problem...

I have a package 'fenris', which depends on libbfd. The problem is it
depends on the EXACT version of the library:

alpha@mentat:~$ ldd which fenris
        libbfd- => /usr/lib/libbfd-

and my package has to depend on exactly the same version of
binutils-dev (containing libbfd) - which causes problems when new
version enters the archive:

Moreover, binutils-dev description says:

   "Note that building Debian packages which depend on the shared libbfd
   is Not Allowed."

So what should I do to fix the problems? Link whole package staticaly??
Thanks in advance for your help...



  _.|._ |_  _.    : Adam Byrtek, alpha@irc.pl
 (_|||_)| |(_|    : gg 1802819, pgp 0xB25952C0

----- End forwarded message -----


  _.|._ |_  _.    : Adam Byrtek, alpha@irc.pl
 (_|||_)| |(_|    : gg 1802819, pgp 0xB25952C0

Reply to: