[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: g++ 3.2 on woody ?

Hi Nikita,

Nikita V. Youshchenko wrote:

I wanted to install g++ 3.2 (instead of 3.1 that is buggy) on our server running woody with several packages from unstable.

I noticed that g++ 3.2 depends on recent libc6. Is it safe to install libc6 from unstable now? Are libdb problems resolved?

I would guess its more safe to build and install gcc 3.2 in
your /usr/local directory tree than upgrading glibc. 3.2 is
not yet released, but thats just a matter of some days (hopefully).
You can find the latest snapshot in ftp://gcc.gnu.org/pub/gcc/ .

Please note that the C++ ABI has been changed with gcc 3.2. The
"old" libraries compiled with g++ 3.0.x or 3.1.x can't be used
with 3.2 anymore.

And you might want to check this page:


Good luck


Reply to: