[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: undefined subroutine in dh_clean while building a package

On Thu, Aug 01, 2002 at 07:05:58PM +0200, Marcel Kolaja wrote:

> I had made some modifications in cron-apt and then I tried to build the
> package. But I got some error. So I tried to build the official 0.0.7
> version but got the same error:
> marcel@oldtimer(pts/4):~/debian/cron-apt/cron-apt$ LC_ALL=C dpkg-buildpackage -rfakeroot
> dpkg-buildpackage: source package is cron-apt
> dpkg-buildpackage: source version is 0.0.7
> dpkg-buildpackage: source maintainer is Ola Lundqvist <opal@debian.org>
> dpkg-buildpackage: host architecture is i386
>  fakeroot debian/rules clean
> dh_testdir
> dh_testroot
> rm -f build-stamp configure-stamp
> # Add here commands to clean up after the build process.
> /usr/bin/make clean
> make[1]: Entering directory `/home/marcel/debian/cron-apt/cron-apt'
> rm man/cron-apt.1*
> rm: cannot remove `man/cron-apt.1*': No such file or directory
> make[1]: [clean] Error 1 (ignored)
> make[1]: Leaving directory `/home/marcel/debian/cron-apt/cron-apt'
> dh_clean
> Undefined subroutine &main::excludefile called at /usr/bin/dh_clean line 64.
> make: *** [clean] Error 255
> marcel@oldtimer(pts/4):~/debian/cron-apt/cron-apt$ 
> The machine I was trying to build the package on is Woody. But it can have
> newer versions of some packages because it had been an old unstable and
> after Woody's release it has been upgraded to Woody. So I tried another
> machine. I got the same error. So I tried another machine. This machine is
> pure Woody. Everything worked. Does anyone have any idea what can be on
> those two machines wrong?

I have posted this message to Czech Linux mailing list too, and I got an
answer with reference to
There I found an advice to try

strace perl -e 'use Debian::Debhelper::Dh_Lib' 2>&1 |grep open |grep Dh_Lib

So I tried it. And I found out I am using
/usr/lib/perl5/Debian/Debhelper/Dh_Lib.pm instead of
/usr/share/perl5/Debian/Debhelper/Dh_Lib.pm. I don't know how it is
possible /usr/lib/perl5/Debian/Debhelper/Dh_Lib.pm was on my system, but
after I had removed it the build of the package worked.

> Marcel Kolaja                              http://www.fi.muni.cz/~xkolaja/


Marcel Kolaja                              http://www.fi.muni.cz/~xkolaja/
NLPlab FI MU                                        http://nlp.fi.muni.cz/
"I do not steal MS software. It is not worth it."       -- Pavel Kaňkovský

P.S. I am sending a copy to the user who originally reported this bug and
to the bug tracking system.

Reply to: