[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [WARNING] Some notes on the upcoming glibc to unstable

On Mon, Jul 29, 2002 at 07:20:54PM +0200, Martin Schulze wrote:
> Ben Collins wrote:
> > The next upload of glibc for unstable will have a drastic change.  The
> > minimum kernel supported will be bumped up to 2.2.0.  This means if you
> > have a 2.0.X kernel running unstable; STAY WITH WOODY.
> Are you going to place a test into the preinst to make it fail if it
> detects a kernel prior to 2.2.0?  (like 2.1.* or 2.0.* for example)

I can do that. I had a similar test for sparc/glibc a long time back
because on sun4m, it required a 2.2.8+ kernel. This would be one of
those times where it would be nice to have system dynamic virtual
provides (like an auto "Provides: system:linux-kernel (= 2.4.8)")

Debian     - http://www.debian.org/
Linux 1394 - http://linux1394.sourceforge.net/
Subversion - http://subversion.tigris.org/
Deqo       - http://www.deqo.com/

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: