[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Little things make the initial install experience painful

Wow. The "rant" reads like it was written by somebody who
watched me spend 12 hours trying to install woody last weekend!
It's a relief to know it's not "just me."

> First try: installer hangs while initially installing packages
> from the net before the reboot, apparently because
> http.us.debian.org is having trouble, although it pings
> happily. User is presented with a frozen progress bar or a
> blank blue screen depending on whether a connection was ever
> made. Ctrl-C works to start over, although this isn't mentioned
> anywhere.

Yup.  Been there, tripped over that. It took me several hours
(and some tcpdumping) to figure out what the problem was. As
you note, switching to a mirror fixed that problem.

> I let the installer run dselect. I still find dselect an
> impossibly confusing program,

Me too.  I've installed Debian about a dozen times over the
past few years, and still am completely unable to do anything
other than break my system when I run dselect.  I assumed I had
some freakish genetic problem and that everybody else was able to
run dselect.

> * libopenldap-runtime loses ("trying to overwrite
> '/usr/share/man/ man5/ldapsearchprefs.conf.5.gz' which is also
> in package libldap2").

This completely stumped me.  I wanted both exim and ssh
installed, and that is apparently impossible.  They depend on
different (conflicting) LDAP libraries.  I don't actually want
either one to use LDAP, but that's a choice made by the package

IMO, an MTA and ssh are way too important to be mutally

> Zeroth, I am going to assume on blind faith that there is a
> good reason to install LDAP.

That one bothered me as well.

> * Electing to retry the install boots me all the way back to tasksel!

Baffled me too.

> This was not what I was expecting at all. If this is intended
> behavior, fix 'retry install' dialog to explain what is about
> to happen.
> * Nothing is checked in tasksel this time! "What is that
> supposed to mean?" Where did my selections go?

That's _exactly_ what I asked when that happened.

> If I press Finish, will all of the software on the machine be
> removed?

Dunno.  Still don't.

> The user needs to be warned, or better, tasksel needs to be
> changed to show previously selected tasks as checked.

My recommendation: Never run tasksel or dselect.  Refuse both,
then just log in and use apt-get to install the packages you
want.  Maybe it takes longer, but it's the only way I've been
able to get a working system.

Oh, and I just found out that even though I thought I installed
"woody", I didn't really, and all of the packages downloaded
were from potato.  So, updated recommendation:

 1) Don't run tasksel or dselect.

 2) Remeber to hand-edit the sources.list file and change
    "stable" to "woody".

> apt eventually tries to install some more packages and we're
> back on the road.

> We lose on the ldap problem and go back through the install
> dialog box loop again.
> A few more packages get installed.


> * All told I have to go through the 'be told about ldap
> lossage, decline tasksel, decline dselect, tell apt yes, be
> told about ldap lossage' SIX TIMES before things stabilize and
> all the packages that can get installed are installed. apt
> should be more clever about doing everything that can be done
> in the face of broken packages.

I always gave up before I went through the loop 6 times.

> In the end I am forced to say 'no' to the retry question,
> giving the installer permission to leave my system in a 'broken
> state'.

Yup.  Using tasksel and dselect I was completely unable to end
up in a "non broken" state.  I tried running "apt-get -f
install" and it was also unable to fix things.

> Then I get a login prompt! Oops, no X for me. I put to you that
> if I, as someone who has installed Linux at least a dozen times
> in his life, can accidently fail to install X -- and realize
> this only to his surprise at the end of the install process --
> then neophytes are doomed.

In my case, what I couldn't figure out was why tasksel/dselect
_did_ install a bunch of X stuff.  All I picked was some SW
development tasks.  I didn't select anything that should have
required X.

I've been using Linux for I-forget-how-long.  I started back in
the 0.99.xx days with Yggdrasil and Slackware on a 25MHz 386
with no floating point and a Hercules mono video card. I've
also installed RedHat, Mandrake, and Debian on systems ranging
from 68K to SPARC to IA32.  I've installed Debian about a dozen
times on a couple different architectures, and every time is
like the first time: It takes 3 or 4 failed attempts, and I'm
frustrated and confused a good portion of the time.  

I really like the ease of updating and adding packages after a
system is installed. I want to like Debian, but it's hard to
when thinking about doing the next install fills you with

Grant Edwards                   grante             Yow!  I always have fun
                                  at               because I'm out of my
                               visi.com            mind!!!

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: