[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#145595: dpkg: --force-overwrite is supposed to be on for releases

On Sun, 2002-05-05 at 16:19, Adam Heath wrote:
> Actually, I am against this.  I want overlaps to be reported.  We need to
> train users to know what this kind of bug is, how to work around it, and how
> to report it.

I have always been against it myself too.

I want overlaps to be reported.

Some overlaps may not matter too much (eg. if a file is moved from one
package to another), but others could cause potentially cause serious
errors in programs to occur (eg. if too packages provide a shared
library with the same name but incompatible ABI).

Somebody posted just recently a script to this mailing list which would
detect if conflicts are wrong.

I recommend using something like this instead.
Brian May <bam@snoopy.apana.org.au>

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: