[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cdrom: lost interrupt

  I realize this is not strictly debian development question, I am
looking for any hints related to how it all works (or doesn't work)
together (kernel ide drivers, VIA MB, IRQs). I did found some
indications that ide was quite broken sometime early in 2.4 series but I
didn't find anything about whether it was (completely) solved or where
to go from here. It looks like HW is OK so I am wondering whether it can
be a kernel problem - that's what I'm hoping to get more info about, I
don't expect you guys to help me to set up the system, just some
pointers to kernel info that might help to shed some light (note that my
problem is quite different from most of the 'lost interrupt' problem in
significant way - my drive works except for audio reading).


    hdc: TDK CDRW321040B, ATAPI CD/DVD-ROM drive
    Linux jojda 2.4.17 #1 Wed Mar 13 01:33:28 PST 2002 i686 unknown
    debian unstable
    VIA Technologies, Inc. VT82C693A/694x (abit)
    kernel config: CONFIG_BLK_DEV_VIA82CXXX=y
    dma access both on and off (same problem)
    32 bit access both on and off (same problem)

  the cdrom is a cd r/rw writer


  when I try to rip the audio it doesn't work much (it works VERY
slowly, hours per songs) and I get the following messages in

Mar 29 00:47:12 localhost kernel: hdc: lost interrupt

  further testing showed that approximately 30-60 reads are OK, then one
failure, 30-60 good reads, one failure (the number of successfull reads

  what works:

  reading raw cd using cat /dev/cdrom|od (it cannot read certain part of
CD but I guess that's the feature of filesystem)

  reading data CDs, when I mount data CD I can read it to my heart
content (and more)

  writing CD: so far I only tried to burn one data CD which worked
without any problems, CD is readable.

  other info:

  the same problem occurs with another CD-ROM drive and also when I
connect cdrom to ide0 (as slave, /dev/hdb). Hardrive connected to both
ide0 and ide1 works without any problems. I also tried to turn off dma
and 32 bit access, no change.

  I don't see any IRQ conflict, ide1 is on 15, nothing else is on 15 (as
listed by BIOS and /proc/interrupts).

  Is it possible that it's a HW problem considering that data cd reading
and buring works? I mean those use IRQs too (and I see the numbers
rising when I read data CD and cat /proc/interrupts). Could it be some
kernel problem? I mean how could the interrupt be lost when trying to
read audio but not when reading data? I don't really know what the
difference is, anybody can shed some light on this?

  BTW cd ripping works fine under windows, even though I've read that it
doesn't mean much 'cause windows often pools hw instead of using IRQ.

  The web search revealed nothing interesting, only that most people who
have lost interrupt problem can't even mount the CD.

  This is what /proc/interrupts says (I haven't used the CD since I
rebooted and I cannot use it now since there's no CD inside and I am not

jojda:/home/erik# cat /proc/interrupts 
  0:   15518706          XT-PIC  timer
  1:       8968          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  SoundBlaster
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  usb-uhci, usb-uhci
 10:      33210          XT-PIC  eth1
 11:     530613          XT-PIC  eth0
 12:      39386          XT-PIC  PS/2 Mouse
 14:     593071          XT-PIC  ide0
 15:         21          XT-PIC  ide1
NMI:          0 
LOC:   15518583 
ERR:          0

  here's what lspci says:

jojda:/home/erik# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo
PRO133x] (rev c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo
MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South]
(rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
(rev 40)
00:0b.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139
(rev 10)
00:0f.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev



To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: