[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libsmpeg0 shlibs is broken, fix it or we shalt lose whatever.

On Mon, 2002-04-01 at 00:09, Junichi Uekawa wrote:
> libsmpeg0 is broken, it will break upgrades from Debian 2.2 to 3.0.

I'm not convinced. Show me real packages that break.
> Either it gets removed (along with whatever list of games we have),
> or fix it.
> Anyone interested in fixing it?

As the maintainer of smpeg, me. But if any packages weren't upgraded
from potato->woody, they would still be broken, because the soname
changed without the package name changing. This is Bad Juju, but
unfortunately I don't think there's a way to fix it this late in the

I'm of the opinion that only user-compiled smpeg-dependent programs will
break, because everything else will have been upgraded. This isn't good,
but there is no way around it as far as I can see. Regardless of what we
do user-compiled programs will need to be recompiled.

Attached is a list of packages which depend on smpeg, and will therefore
have to be removed if smpeg is removed.

Joe Drew <hoserhead@woot.net> <drew@debian.org>

Please encrypt email sent to me.
Reverse Depends: 
  prboom,libsmpeg0 0.4.3-2
  prboom,libsmpeg0 0.4.3-2
  smpeg-xmms,libsmpeg0 0.4.3-2
  smpeg-plaympeg,libsmpeg0 0.4.4-7
  smpeg-gtv,libsmpeg0 0.4.4-7
  pysol-sound-server,libsmpeg0 0.4.3-2
  pygame,libsmpeg0 0.4.4-7
  libsmpeg-dev,libsmpeg0 0.4.4-7
  libsdl-ruby,libsmpeg0 0.4.4-7
  libsdl-mixer1.2,libsmpeg0 0.4.4-7
  libopenal0,libsmpeg0 0.4.4-7
  ksmp3play,libsmpeg0 0.4.3-2
  ganso,libsmpeg0 0.4.3-2
  frozen-bubble-lib,libsmpeg0 0.4.4-7
  chromium,libsmpeg0 0.4.3-2

Reply to: