[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#139185: dict-gcide: Build-Depends-Indep: dictd

Edward Betts <edward@debian.org> writes:

> Santiago Vila <sanvila@unex.es> wrote:
> > In this case you should decide whether you want the dictionary in
> > the .deb binary package to be always compressed or never. Consider that your
> > package will be built for 10 other different architectures.
> I think it is an `Architecture: all' package. I agree it should have a
> build-depends on dictd.

     Yes, it is `Architecture: all', so the builds will probably never
build it.

     I seem to be in a small minority on this.  Since dictzip is not
_required_ to be present on the system in order to build the binary
packages from the source package I believe it would be a policy
violation to call it a Build-Depends-Indep. since the Makefile and
configure make dictzip optional.  To resolve this, I will modify the
Makefile so dictzip _is_ required, and add dictd to the
`Build-Depends-Indep:' in the next upload.

  |_)  _  |_       Robert D. Hilliard      <hilliard@debian.org>
  |_) (_) |_)      1294 S.W. Seagull Way   <bob@bobhilliard.net>
                   Palm City, FL  USA      GPG Key ID: 390D6559 
                                           PGP Key ID: A8E40EB9

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: