[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

weird deps problem inhibit entering testing

Hi all,
  I have a weird problem that inhibits a bounce of my packages enter
testing. I've read the testing FAQ and I've read a lot of times
update_output and update_excuses but I can't understand why that package
will not enter testing.

I'm talking about source package: pxp netstring netclient xstr.
All of them are reported as valid candidates in update_excuses and have
dep relations between themselves.
The main problem is that I changed the name of the generated binary
packages, in past the relation between source and binary packages were:

pxp -> ocaml-pxp
netstring -> ocaml-netstring
netclinet -> ocaml-netclient
xstr -> ocaml-xstr

Now we have almost written a debian OCaml policy and I have changed the
name of the binary packages as follows

pxp -> libpxp-ocaml-dev
netstring -> libnetstring-ocaml-dev
netclient -> libnetclient-ocaml-dev
xstr -> libxstr-ocaml-dev

I've fixed the deps using Replaces, Provides and Conflicts as policy
states and all the packages are installable (try on your unstable box
and you will have a smooth upgrade). So I think that no package will be
broken if these packages enter _all together_ testing.

Anyway update_excuses still reports:

    + Depends: netclient netstring
    + Depends: netclient xstr
    + Depends: pxp netstring

and update_output still reports "skipped" for all the four packages.

Anybody can help me in solving such issues?


Stefano Zacchiroli - undergraduate student of CS @ Univ. Bologna, Italy
zack@cs.unibo.it | ICQ# 33538863 | http://www.cs.unibo.it/~zacchiro
"I know you believe you understood what you think I said, but I am not
sure you realize that what you heard is not what I meant!" -- G.Romney

Attachment: pgpfLylo4tb3n.pgp
Description: PGP signature

Reply to: