[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#126567: libreadline4 no longer respects directory separators in tab-completion

On Thu, 27 Dec 2001, Matthias Klose wrote:

> [CC to debian-devel, asking if report #126567 is reproduceable]
> Bill Gribble writes:
> > > I simply cannot reproduce the behaviour you describe.
> > 
> > Well, why don't you describe for me what you have tried to do.  "Simply
> > cannot reproduce" could mean just about anything, including that you
> > haven't tried.  How about this: 
> > 
> >   $ mkdir foo
> >   $ touch foo/bar 
> >   $ cd fo<TAB> 
> >  
> > On my machine, 'fo' is replaced with 'foo/bar'.  That is incorrect. 
> > 
> > It doesn't seem to me that you are interested in locating this problem. 
> > I'm taking my time to file a bug report in an effort to help the Debian
> > project.  In your role as maintainer, please do me the courtesy of at
> > least pretending to be interested.  
> calm down and don't flame around. the initial report did have an
> example which I tested on more than one machine. Then I tagged the
> report as unreproduceable to mark the current state. If I were not
> interested I would have closed the report without notifying you.

	Can we confirm whether this is a libreadline thing?  It could be
bash's programmable completion feature.  Has the user defined any
`complete`s?  If so, maybe he should look at what he's set for his


Reply to: