[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Buildd problems with Build-depends

Hi.  I'm having all sorts of problems with my latest upload of 
libreadline-java, in that every single autobuild has failed.  They're all 
coming up with messages like:

Sorry, but the following packages have unmet dependencies:
  gcj: Depends: gcj-3.0 but it is not going to be installed
       Depends: g++-3.0 but it is not going to be installed
  libgcj2-dev: Depends: gcj-3.0 (>= 1:3.0.2-4) but it is not going to be 
E: Sorry, broken packages
apt-get failed.

The Build-Depends line is:

Build-Depends: debhelper (>> 3.0.0), libedit-dev, libreadline4-dev, jikes, 
fastjar | kaffe, gcj | kaffe, libgcj2-dev | kaffe

I can't see any inherent conflicts in here, and AFAICT packages g++-3.0, 
gcc-3.0, gcj and libgcj2-dev are available (with the required versions) for a 
number of the architectures whose builds failed.

I'm well and truly confused as to what the problem is and whether it's my 
problem or not.  If anyone has any ideas they'd be most welcome.

See http://buildd.debian.org/build.php?&pkg=libreadline-java for the entire 
logs of each failed build.

TIA - Ben.


Ben Burton
benb@acm.org  |  bab@debian.org
Public Key: finger bab@debian.org

... the brain-damaged Honorable Member for Bruce made his first parliamentary
contribution since being elected, by calling a quorum to silence me for three
	- Paul Keating, on Ken Aldred

Reply to: