[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XML problem


I was asked to publish an XML service at my web server.
After reading some docs on apache.org and w3c.org I understand cocoon is
the tool for this. I decided to install cocoon2-example first on my
workstation to see how it works. I just wrote 'apt-get install
cocoon2-axample' at the console.
On this workstation I use all Debian package-sets so JDK was taken from
non-free. It apperars tomcat works, however cocoon2 doesn't. It says
something about wrong classes version.
I tried cocoon-example then. Now it's better, I can see cocoon
directory, but I'm unabke to see xml files. Command like
http://localhost:8081/cocoon/index.xml gives me:
Not Found (404)

Original request: /cocoon/index.xml 

Not found request: /cocoon/index.xml 

I tried to install cocoon on my server. There, I use only main and
non-US sets. The installer pointed me at ibm.com for JDK, however I
couldn't find it there, so I used google.com and found it somewhere in
France. It was installed properly (at least the installer said so) and I
can see tomcat is using this, but I'm unable to connect to port 8081.

I use the newest packages (SID) on both boxen.
Marek L. Kozak

Reply to: