[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rdate can't connect socket

Samuel Tardieu <sam@debian.org> writes:
> On 16/09, Bob Hilliard wrote:
> |      This has worked consistently for a long time, but for the past
> | week or two it returns:
> |      rdate: Could not connect socket: Connection refused
> | 
> |      This message returns almost instantly - too quickly, I believe,
> | to be a connection refused at the remote server.
> | 
> |      Can this be a socket on my machine that refuses a connection?
> Did you by chance update your firewall? Could it be rejecting this outgoing
> connection?
     I don't have a firewall as such.  I deny ALL in /etc/host.deny,
and have most services commented out in /etc/inetd.conf, but nothing
has changed in these areas since long before rdate started failing.
However, see below.

"Michael B. Taylor" <mtaylor@vorticity.engr.utk.edu> writes:

> I cant say whether your theory is correct or not.  It sounds
> plausible.  However, I did have the same problem a while
> back.  I am pretty sure it the remote server refusing.  I
> resolved the problem by installing the nptdate package, and
> using my name server as a time host also.

     You seem to be right.  I have successfully tried rdate

     As a matter of interest, I have a rather clueless isp (local
cable company) using M$ software.  The time returned from its
nameserver is three to four minutes slow.  My domain is hosted by
Greenbush Technologies, which uses Debian, and is run by a clueful
administrator.  That nameserver gives the correct time.

     Thanks to both of you for your responses.

  |_)  _  |_       Robert D. Hilliard      <hilliard@debian.org>
  |_) (_) |_)      1294 S.W. Seagull Way   <bob@bobhilliard.net>
                   Palm City, FL  USA      GPG Key ID: 390D6559 
                                           PGP Key ID: A8E40EB9

Reply to: