[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

aptitude, install-info, gzip strange behaviour

During the recent bug in gnupg 1.0.6-1
I tried to upgrade gnupg and mtools using aptitude.

mtools did unpack, gnupg of course not.
In such situations aptitude tries to help by running
dpkg --configure -a
But this time it didn't work.

Configuring mtools resulted in broken pipe from gzip
to install-info, which in itself is as far as I was able
to read from install-info completely normal and happens all the time.
This time it caused install-info to stop with
gzip: stdout: Broken pipe
install-info: read gzip -d </usr/share/info/mtools.info.gz |: 256

not a sign that install-info knew anything about the SIGPIPE.

But of course upgrading mtools without touching gnupg
worked fine, running dpkg --configure -a from the shell worked as well.

Should it be reported as a bug in aptitude? I'm very unsure about that.

PS. I'm not on debian-devel yet, so please cc me if possible.

Michal Politowski -- mpol@lab.icm.edu.pl
Warning: this is a memetically modified message

Reply to: