[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Automake 2.50 migration strategy, as implemented

Adrian Bunk writes:
> I know that it's sometimes some work to get a package building on stable
> that has a build dependency on debhelper (>= 3.0) . Shall we prohibit
> maintainers from setting this build dependency?

Perhaps build-depends needs some sort of priority scheme, along the lines of

        build-depends: foo
        build-depends-strict: foo (>=1.2)
        build-depends-paranoid: foo (==1.2-4)

The default would be to ignore 'strict' and 'paranoid', but the
autobuilders could be set to follow one or the other.
John Hasler
john@dhh.gt.org (John Hasler)
Dancing Horse Hill
Elmwood, WI

Reply to: